Spring Data Commons依赖管理
寂寞的心情wang 发布于2021-09 浏览:2489 回复:0
0
收藏

原标题:Spring认证|Spring Data Commons依赖管理


由于各个 Spring Data 模块的启动日期不同,它们中的大多数带有不同的主要和次要版本号。找到兼容版本的最简单方法是依赖我们随定义的兼容版本一起提供的 Spring Data Release Train BOM。在 Maven 项目中,您将在POM的部分中声明此依赖项,如下所示:

示例 1. 使用 Spring Data 发布系列 BOM

    org.springframework.data

    spring-data-bom

    2021.0.4

    import

    pom

当前的发布系列版本是2021.0.4. 火车版本使用带有图案的calverYYYY.MINOR.MICRO。$GA 版本和服务版本的版本名称遵循以下模式,所有其他版本遵循以下模式:$-$,其中modifier可以是以下之一:

SNAPSHOT:当前快照

M1, M2, 等等:里程碑

RC1, RC2, 等等:发布候选

您可以在我们的Spring Data 示例存储库中找到使用 BOM 的工作示例。有了它,您就可以在块中声明要使用的 Spring Data 模块,而无需在块中指定版本,如下所示:

示例 2. 声明对 Spring Data 模块的依赖

  org.springframework.data

  spring-data-jpa

使用 Spring Boot 进行依赖管理

Spring Boot 会为您选择最新版本的 Spring Data 模块。如果您仍想升级到更新的版本,请将spring-data-releasetrain.version属性设置为您想要使用的训练版本和迭代。

弹簧框架

当前版本的 Spring Data 模块需要 Spring Framework 5.3.9 或更高版本。这些模块也可能与该次要版本的较旧错误修复版本一起使用。但是,强烈建议使用该代中的最新版本。

收藏
点赞
0
个赞
TOP
切换版块