支持易语言吗?
czy300030 发布于2019-06 浏览:1620 回复:5
0
收藏
快速回复

支持易语言吗?支持易语言吗?支持易语言吗?

收藏
点赞
0
个赞
共5条回复 最后由用户已被禁言回复于2022-04
#6verykeen回复于2019-06

这操作真的服

0
#5用户已被禁言回复于2019-06
#4 熊猫TV丶老鸟回复
这给是我最近才写一个 还不错   就是在控制播放的时候 有点麻烦 重复的提交合成是无效的  
展开

好的,感谢您的分享

0
#4熊猫TV丶老鸟回复于2019-06

这给是我最近才写一个 还不错  

就是在控制播放的时候 有点麻烦 重复的提交合成是无效的

 

0
#3熊猫TV丶老鸟回复于2019-06

.版本 2
.支持库 internet

.子程序 语音合成, 字节集
.参数 tex, 文本型, , 合成的文本,使用UTF-8编码,请注意文本长度必须小于1024
.参数 lan, 文本型, , 语言选择,填写zh
.参数 tok, 文本型, , 开放平台获取到的开发者access_token
.参数 ctp, 文本型, , 客户端类型选择,web端填写1
.参数 cuid, 文本型, , 不管他,老是出错,直接填写“xxx”
.参数 spd, 文本型, , 语速,取值0-9,一般为5
.参数 pit, 文本型, , 音调,取值0-9,一般为5
.参数 vol, 文本型, , 音量,取值0-9,一般为5
.参数 per, 文本型, , 取值0-1, 0为女生,1为男生
.局部变量 数据, 字节集

数据 = HTTP读文件 (“http://tsn.baidu.com/text2audio?tex=” + tex + “&lan=” + lan + “&tok=” + tok + “&ctp=” + ctp + “&cuid=” + cuid + “&spd=” + spd + “&pit=” + pit + “&vol=” + vol + “&per=” + per)
返回 (数据)

 

 

.版本 2
.支持库 eAPI
.支持库 eMMedia
.支持库 spec
.支持库 wmp9

.子程序 _按钮_测试朗读_被单击
.局部变量 i, 整数型
.局部变量 获取到的名字, 文本型

获取到的名字 = 组合框_发言人.取项目文本 (组合框_发言人.现行选中项)
.如果 (文件是否存在 (取运行目录 () + “\” + 获取到的名字 + “.mp3”) = 真)
获取到的名字 = “\” + 获取到的名字 + “.mp3”
强制删除文件 (取运行目录 () + 获取到的名字)
.否则
.如果真 (写到文件 (取运行目录 () + “\” + 获取到的名字 + “.mp3”, 语音合成 (URL_UTF8编码 (“欢迎使用久橙说说西瓜弹幕点歌助手!”), “zh”, “你自己的access_token”, “1”, 到文本 (取本机网卡物理地址 ()), 到文本 (滑块条_语速.位置), 到文本 (滑块条_音调.位置), 到文本 (滑块条_音量.位置), 到文本 (发言人选择 (到文本 (组合框_发言人.现行选中项))))))
.如果真 (媒体播放_弹幕朗读.打开 (取运行目录 () + “\” + 组合框_发言人.取项目文本 (组合框_发言人.现行选中项) + “.mp3”))
媒体播放_弹幕朗读.播放 (-1, )
强制删除文件 (取运行目录 () + 获取到的名字)

.如果真结束

.如果真结束

.如果结束

调试输出 (播放器1.状态)

0
#2用户已被禁言回复于2019-06

API支持任意操作系统,任意编程语言,只要可以对百度语音服务器发起http请求的,均可以使用本接口。

0
TOP
切换版块