小米8,Android9.0 crash
快捷通支付服务有限公司 发布于2019-04 浏览:5330 回复:34
0
收藏

小米8,Android 9.0,出现了crash。

java.lang.NoClassDefFoundError: Failed resolution of: Lorg/apache/http/message/BasicNameValuePair;
at com.baidu.tts.e.a.c(StatHelper.java:192)
at com.baidu.tts.e.a.a(StatHelper.java:154)
at com.baidu.tts.e.a.b(StatHelper.java:130)
at com.baidu.tts.e.a.a(StatHelper.java:88)
at com.baidu.tts.e.b.run(StatThread.java:19)

难道sdk还在用httpClient????

收藏
点赞
0
个赞
共34条回复 最后由用户已被禁言回复于2022-04
#29用户已被禁言回复于2019-12

您好,看到您之前有关注百度语音SDK关于Androd 9.0 28编译问题,特此通知您目前官网上最新版本SDK已支持Androd 9.0 28编译,请您尽快升级。谢谢!

0
#35用户已被禁言回复于2020-04
#34 梅瑰儿回复
android:name="org.apache.http.legacy" android:required="false" />
展开

你好,请问你这里是有什么问题?请详细描述下

0
#34梅瑰儿回复于2020-04



android:name="org.apache.http.legacy"
android:required="false" />

0
#33用户已被禁言回复于2019-12
#4 sunny高傲小生回复
这个问题解决了吗?我也碰到了  Android9.0 

您好,看到您之前有关注百度语音SDK关于Androd 9.0 28编译问题,特此通知您目前官网上最新版本SDK已支持Androd 9.0 28编译,请您尽快升级。谢谢!

0
#32用户已被禁言回复于2019-12
#18 150******59回复
我刚刚就只是把  compileSdkVersion 28、targetSdkVersion 28改成 compileSdkVersion 27、targetSdkVersion 27,这样是正常的,没有下面的问题
展开

您好,看到您之前有关注百度语音SDK关于Androd 9.0 28编译问题,特此通知您目前官网上最新版本SDK已支持Androd 9.0 28编译,请您尽快升级。谢谢!

0
#31用户已被禁言回复于2019-12
#23 傻不拉几的你0回复
请问什么时候能适配28呢。

您好,看到您之前有关注百度语音SDK关于Androd 9.0 28编译问题,特此通知您目前官网上最新版本SDK已支持Androd 9.0 28编译,请您尽快升级。谢谢!

0
#30用户已被禁言回复于2019-12
#27 stormzlb回复
values-v28\values-v28.xml:7: error: resource android:attr/dialogCornerRadius not found.   编译版本换成27   出现找不到28里面的东西,有哪位遇到过  怎么解决
展开

您好,看到您之前有关注百度语音SDK关于Androd 9.0 28编译问题,特此通知您目前官网上最新版本SDK已支持Androd 9.0 28编译,请您尽快升级。谢谢!

0
#28用户已被禁言回复于2019-08
#27 stormzlb回复
values-v28\values-v28.xml:7: error: resource android:attr/dialogCornerRadius not found.   编译版本换成27   出现找不到28里面的东西,有哪位遇到过  怎么解决
展开

可以再官网低保查找qq支持群交流

0
#27stormzlb回复于2019-07
#26 用户已被禁言回复
你可以将编译先调整成27。

values-v28\values-v28.xml:7: error: resource android:attr/dialogCornerRadius not found.

 

编译版本换成27   出现找不到28里面的东西,有哪位遇到过  怎么解决

0
#26用户已被禁言回复于2019-07
#25 stormzlb回复
已经最新sdk   还报错  修复了吗?

你可以将编译先调整成27。

0
#25stormzlb回复于2019-07

已经最新sdk   还报错  修复了吗?

0
#24用户已被禁言回复于2019-07
#23 傻不拉几的你0回复
请问什么时候能适配28呢。

需求会有排期,目前已经反馈到后端同事了,请耐心等待。

0
#23傻不拉几的你0回复于2019-07
#22 用户已被禁言回复
语音合成还不支持level 28 ,最新版本在这里下载 https://ai.baidu.com/sdk
展开

请问什么时候能适配28呢。

0
#22用户已被禁言回复于2019-07
#21 傻不拉几的你0回复
在哪下载最新的sdk呢。。找到的都是去年的。

语音合成还不支持level 28 ,最新版本在这里下载 https://ai.baidu.com/sdk

0
#21傻不拉几的你0回复于2019-07
#6 用户已被禁言回复
后台同学已经解决了,上线会有新的版本,目前在内部测试bug,近期内会更新以适配 android 9.0
展开

在哪下载最新的sdk呢。。找到的都是去年的。

0
#20150******59回复于2019-06
#19 用户已被禁言回复
其他的改了也没事吗?编译只要还是27就可以。是这样吗?

对的,是这样的

 

0
#19用户已被禁言回复于2019-06
#18 150******59回复
我刚刚就只是把  compileSdkVersion 28、targetSdkVersion 28改成 compileSdkVersion 27、targetSdkVersion 27,这样是正常的,没有下面的问题
展开

其他的改了也没事吗?编译只要还是27就可以。是这样吗?

0
#18150******59回复于2019-06
#16 用户已被禁言回复
不要修改是否会有这样情况呢?

我刚刚就只是把  compileSdkVersion 28、targetSdkVersion 28改成 compileSdkVersion 27、targetSdkVersion 27,这样是正常的,没有下面的问题

0
#17liguanghui2588回复于2019-06

楼主在手机上搞语音识别

0
#16用户已被禁言回复于2019-06
#15 150******59回复
(1) 我跑的是     “语音合成”  的demo (2)我周五下的,应该是最新的sdk (3)我修改了  1、 gradle-wrapper.properties 里的变量 我改成distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.1-all.zip;  2、外层 build.gradle  里的配置   我改成classpath 'com.android.tools.build:gradle:3.3.2';     3、主model 里build.gradle   compileSdkVersion 28,targetSdkVersion 28
展开

不要修改是否会有这样情况呢?

0
TOP
切换版块