首页 Paddle框架 帖子详情
paddle在ubuntu20.04环境下安装出现错误 已解决
收藏
快速回复
Paddle框架 问答学习资料炼丹技巧 368 3
paddle在ubuntu20.04环境下安装出现错误 已解决
收藏
快速回复
Paddle框架 问答学习资料炼丹技巧 368 3

我在ubuntu20.04下试图安装torch与paddle

在nvidia官网下载了驱动,现在已经是cuda11.7的驱动了

然后按照里面的paddle安装的要求下载了cuda11.1 toolkit(但是安装最后一步,我发现还是安上了cuda11.7,nvcc -V看到的是11.7版本)

以及适用于cuda11.0/11.1/11.2 的cudnn8.1.1

创建了 torch 环境以及paddle环境

在torch环境下,没有报错,cuda可以正常运行

但是paddle环境下,import paddle,创建一个tensor就会报错,说cuda/cudnn可能有问题

我觉得可能是cuda驱动以及对应toolkit的问题,因为都是11.7的

然后我又把cuda驱动、cuda 工具包卸载,找到了2年前的驱动包,

安装真的是巨麻烦!!!

从cuda安装就卡住了。因为gcc是9.4.0的,我必须降级到9.3.0的。

国内关于这一点的教程乱七八糟的,我尝试了很多,都是两年前的教程了,当时安装本身就是9.3.0的了。所以教程基本都是9.3.0降级到6.几甚至更低。并且评论区一片骂声,净是错误。

我在google尝试解决该问题,找到一个答案,告知最好不要更改系统默认的gcc版本,这可能会造成意想不到的错误。

我该怎么解决?????安装个paddle环境要求这么呆板么?还是我哪里没装好??但是没状好,torch也一定会报错。

有小伙伴近期在ubuntu20.04装过paddle cuda11这一些列的环境吗??求助

d
dreamTyou
已解决
2# 回复于2022-06
出问题只能帮到这里了。这里不让贴链接[图片]
展开
0
收藏
回复
全部评论(3)
时间顺序
d
dreamTyou
#2 回复于2022-06

出问题只能帮到这里了。这里不让贴链接

0
回复
起个啥名字了
#3 回复于2022-06

说个事实,安装Tensorflow与Pytorch的难度比Paddlepaddle难多了。

几个点注意下:

1. 显卡的驱动可以安装最新的,安装后通过命令查询: nvida-smi, 里面的CUDA版本可以忽略。

2. 最新的CUDA只支持到11.2,安装高版本的100%出错,高一点都不行,不然 CUDA 11.2.2都不行。

3. cudnn下载tar包格式的,设置好环境变量就好,这个下载支持11.x的包就行。

0
回复
d
dreamTyou
#4 回复于2022-06
说个事实,安装Tensorflow与Pytorch的难度比Paddlepaddle难多了。 几个点注意下: 1. 显卡的驱动可以安装最新的,安装后通过命令查询: nvida-smi, 里面的CUDA版本可以忽略。 2. 最新的CUDA只支持到11.2,安装高版本的100%出错,高一点都不行,不然 CUDA 11.2.2都不行。 3. cudnn下载tar包格式的,设置好环境变量就好,这个下载支持11.x的包就行。
展开

我的是cuda版本有问题。按照nvidia官网给的network安装怎么装都是11.7. 后来搞成local安装,就变成11.1,就好了。

0
回复
需求/bug反馈?一键提issue告诉我们
发现bug?如果您知道修复办法,欢迎提pr直接参与建设飞桨~
在@后输入用户全名并按空格结束,可艾特全站任一用户